media-sound/qsynth: x86 stable wrt bug #720454
[gentoo.git] / media-sound / freebirth / freebirth-0.3.2-r1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit eutils toolchain-funcs
6
7 DESCRIPTION="Free software bass synthesizer step sequencer"
8 HOMEPAGE="http://freshmeat.net/releases/8834"
9 SRC_URI="http://www.bitmechanic.com/projects/freebirth/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="amd64 ~ppc sparc x86"
14 IUSE=""
15
16 RDEPEND="x11-libs/gtk+:2"
17 DEPEND="${RDEPEND}
18         virtual/pkgconfig"
19
20 src_prepare() {
21         epatch "${FILESDIR}"/${P}-gentoo-2.patch \
22                 "${FILESDIR}"/${P}-segfault.patch
23 }
24
25 src_compile() {
26         tc-export CC
27         emake
28 }
29
30 src_install() {
31         dobin ${PN}
32
33         insinto /usr/share/${PN}/raw
34         doins raw/*.raw
35
36         dodoc CHANGES NEXT_VERSION README
37
38         doicon xpm/${PN}.xpm
39         make_desktop_entry ${PN} ${PN}
40 }