dev-util/ccache: arm64 stable (bug #725006)
[gentoo.git] / media-sound / fmdrv / fmdrv-1.0.7.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit eutils toolchain-funcs
6
7 DESCRIPTION="Console mode MIDI player with builtin userland OPL2 driver"
8 HOMEPAGE="https://bisqwit.iki.fi/source/fmdrv.html"
9 SRC_URI="https://bisqwit.iki.fi/src/arch/${P}.tar.bz2"
10
11 LICENSE="fmdrv GPL-2" # GPL-2 only
12 SLOT="0"
13 KEYWORDS="amd64 x86"
14
15 src_prepare() {
16         epatch "${FILESDIR}"/${P}-ioperm.patch
17 }
18
19 src_configure() { :; } # it is a fake
20
21 src_compile() {
22         emake fmdrv \
23                 CC="$(tc-getCC)" CXX="$(tc-getCXX)" \
24                 CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" \
25                 LDFLAGS="${LDFLAGS}"
26 }
27
28 src_install() {
29         dobin fmdrv
30         dodoc README
31         dohtml README.html
32 }
33
34 pkg_postinst() {
35         elog "If you want to use AdLib (FM OPL2), you need to setuid /usr/bin/fmdv."
36         elog "chmod 4711 /usr/bin/fmdrv"
37 }