kde-apps: Drop KDE Applications 20.04.0
[gentoo.git] / media-sound / flake / flake-0.11.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="An alternative to the FLAC reference encoder"
9 HOMEPAGE="http://flake-enc.sourceforge.net"
10 SRC_URI="mirror://sourceforge/flake-enc/${P}.tar.bz2"
11
12 LICENSE="LGPL-2.1"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15
16 src_configure() {
17         # NIH configure script
18         ./configure \
19                 --cc="$(tc-getCC)" \
20                 --prefix="${D}"/usr \
21                 --disable-opts \
22                 --disable-debug \
23                 --disable-strip || die "configure failed"
24 }
25
26 src_compile() {
27         emake -j1
28 }
29
30 src_install() {
31         dobin flake/flake
32         doheader libflake/flake.h
33         dolib.a libflake/libflake.a
34         dodoc Changelog README
35 }