*/*: update LXQt HOMEPAGE
[gentoo.git] / media-sound / darksnow / darksnow-0.7.1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit autotools eutils gnome2-utils
7
8 DESCRIPTION="Streaming GTK+ Front-End based on Darkice Ice Streamer"
9 HOMEPAGE="http://darksnow.radiolivre.org"
10 SRC_URI="http://darksnow.radiolivre.org/pacotes/${P}.tar.gz"
11
12 SLOT="0"
13 LICENSE="GPL-2"
14 KEYWORDS="amd64 ppc sparc x86"
15 IUSE=""
16
17 PDEPEND=">=media-sound/darkice-1.2"
18 RDEPEND=">=x11-libs/gtk+-2.14.0:2"
19 DEPEND="${RDEPEND}
20         virtual/pkgconfig"
21
22 src_prepare() {
23         epatch "${FILESDIR}"/${P}-Makefile.patch
24         eautoreconf
25 }
26
27 src_install() {
28         emake DESTDIR="${D}" install
29         dodoc documentation/{CHANGES,CREDITS,README*}
30         make_desktop_entry ${PN} "DarkSnow" ${PN}
31 }
32
33 pkg_postinst() {
34         gnome2_icon_cache_update
35 }
36
37 pkg_postrm() {
38         gnome2_icon_cache_update
39 }