media-sound/alsa-utils: stable 1.2.2 for sparc, bug #720810
[gentoo.git] / media-sound / combine_wave / combine_wave-0.3.1-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="sync up 2 audio ch. and/or combine 2 mono audio ch. into one stereo wave ch"
9 HOMEPAGE="http://panteltje.com/panteltje/dvd/"
10 SRC_URI="http://panteltje.com/panteltje/dvd/${P}.tgz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 DOCS=( CHANGES README combine_wave.man )
18
19 PATCHES=( "${FILESDIR}/${P}-overflow.patch" )
20
21 src_prepare() {
22         default
23         # fix makefile
24         sed -i -e "s:gcc:\$(CC):g" -e "s:= -O2:+=:g" \
25                 -e "s:\( -o \): \$(LDFLAGS)\1:g" Makefile || die "sed Makefile failed"
26 }
27
28 src_configure() {
29         tc-export CC
30 }
31
32 src_install() {
33         dobin combine_wave
34         einstalldocs
35 }