media-sound/pavucontrol-qt: add version 0.15.0
[gentoo.git] / media-sound / cmusfm / cmusfm-0.3.1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit autotools readme.gentoo-r1
6
7 DESCRIPTION="Last.fm scrobbler for cmus music player"
8 HOMEPAGE="https://github.com/Arkq/cmusfm"
9 SRC_URI="https://github.com/Arkq/cmusfm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
10
11 LICENSE="GPL-3"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="libnotify"
15
16 CDEPEND="net-misc/curl
17         dev-libs/openssl:0=
18         libnotify? ( >=x11-libs/libnotify-0.7 )"
19 DEPEND="${CDEPEND}
20         virtual/pkgconfig"
21 RDEPEND="${CDEPEND}
22         media-sound/cmus"
23
24 src_prepare() {
25         default
26         eautoreconf
27         DOC_CONTENTS="Please refer to the README.md file before running cmusfm the first time."
28 }
29
30 src_configure() {
31         econf $(use_enable libnotify)
32 }
33
34 src_install() {
35         default
36         readme.gentoo_create_doc
37 }
38
39 pkg_postinst() {
40         readme.gentoo_pkg_postinst
41 }