dev-python/natsort: Support newer python
[gentoo.git] / media-sound / bristol / bristol-0.60.9.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="4"
5
6 inherit eutils autotools-utils
7
8 DESCRIPTION="Synthesizer keyboard emulation package: Moog, Hammond and others"
9 HOMEPAGE="https://sourceforge.net/projects/bristol"
10 SRC_URI="mirror://sourceforge/bristol/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="alsa oss static-libs"
16 # osc : configure option but no code it seems...
17 # jack: fails to build if disabled
18
19 RDEPEND=">=media-sound/jack-audio-connection-kit-0.109.2
20         alsa? ( >=media-libs/alsa-lib-1.0.0 )
21         x11-libs/libX11"
22 # osc? ( >=media-libs/liblo-0.22 )
23 DEPEND="${RDEPEND}
24         x11-proto/xproto
25         virtual/pkgconfig"
26
27 DOCS=( AUTHORS ChangeLog HOWTO NEWS README )
28
29 PATCHES=( "${FILESDIR}"/${P}-cflags.patch )
30
31 src_prepare() {
32         autotools-utils_src_prepare
33         eautoreconf
34 }
35
36 src_configure() {
37         local myeconfargs=(
38                 --disable-version-check
39                 $(use_enable alsa)
40                 $(use_enable oss)
41                 #$(use_enable osc liblo)
42         )
43         autotools-utils_src_configure
44 }