media-sound/qmmp: Removed old
[gentoo.git] / media-sound / bplay / bplay-0.991.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="No-frills command-line buffered player and recorder"
9 HOMEPAGE="http://www.amberdata.demon.co.uk/bplay/"
10 SRC_URI="http://www.amberdata.demon.co.uk/bplay/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 hppa ~ppc sparc x86"
15
16 src_compile() {
17         emake \
18                 LDFLAGS="${LDFLAGS}" \
19                 CFLAGS="${CFLAGS} -DUSEBUFFLOCK" \
20                 CC="$(tc-getCC)" bplay
21 }
22
23 src_install() {
24         newbin bplay bplay-bin
25         dosym bplay-bin /usr/bin/brec
26         doman brec.1
27         newman bplay.1 bplay-bin.1
28         einstalldocs
29 }