media-sound/alsa-utils: stable 1.2.2 for ppc64, bug #720810
[gentoo.git] / media-sound / awesfx / awesfx-0.5.1e.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="AWE32 Sound Driver Utility Programs"
7 HOMEPAGE="http://ftp.suse.com/pub/people/tiwai/awesfx"
8 SRC_URI="http://ftp.suse.com/pub/people/tiwai/${PN}/${P}.tar.bz2"
9
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="amd64 ~ppc ~sparc x86"
13 IUSE=""
14
15 DEPEND="media-libs/alsa-lib"
16 RDEPEND="${DEPEND}"
17
18 BANK_LOC="${EPREFIX}/usr/share/sounds/sf2"
19
20 DOCS=( AUTHORS ChangeLog README SBKtoSF2.txt samples/README-bank )
21
22 src_configure() {
23         econf \
24                 --with-sfpath=${BANK_LOC}
25 }
26
27 src_install() {
28         default
29
30         rm "${ED}"/usr/share/sounds/sf2/README-bank || die
31         newinitd "${FILESDIR}"/sfxload.initd sfxload
32         newconfd "${FILESDIR}"/sfxload.confd sfxload
33 }
34
35 pkg_postinst() {
36         elog "Copy your SoundFont files from the original CDROM"
37         elog "shipped with your soundcard to ${BANK_LOC}."
38 }