media-sound/quodlibet: x86 stable wrt bug #721406
[gentoo.git] / media-sound / abcmidi / abcmidi-2020.01.22.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit autotools
7
8 MY_P="abcMIDI-${PV}"
9 DESCRIPTION="Programs for processing ABC music notation files"
10 HOMEPAGE="https://ifdo.ca/~seymour/runabc/top.html"
11 SRC_URI="https://ifdo.ca/~seymour/runabc/${MY_P}.zip"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="examples"
17
18 DEPEND="app-arch/unzip"
19
20 S=${WORKDIR}/${PN}
21
22 src_prepare() {
23         local PATCHES=( "${FILESDIR}"/${PN}-2016.05.05-docs.patch )
24         default
25
26         rm configure Makefile || die
27         sed -i "s:-O2::" configure.ac || die
28
29         eautoreconf
30 }
31
32 src_install() {
33         default
34         dodoc doc/{AUTHORS,CHANGES,abcguide.txt,abcmatch.txt,history.txt,readme.txt,yapshelp.txt}
35
36         if use examples ; then
37                 docinto examples
38                 dodoc samples/*.abc
39         fi
40 }