Remove comedilib-9999-comedi.i.patch.
[wtk-overlay.git] / media-sound / abcmidi / abcmidi-2011.01.01.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6
7 inherit eutils toolchain-funcs versionator
8
9 MY_PV=$(replace_all_version_separators -)
10 DESCRIPTION="Programs for processing ABC music notation files"
11 HOMEPAGE="http://abc.sourceforge.net/abcMIDI/"
12 SRC_URI="mirror://sourceforge/abc/abcMIDI-${MY_PV}.zip"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 S=${WORKDIR}/${PN}
20
21 src_prepare() {
22         epatch "${FILESDIR}"/${PN}-2010.02.09_gentoo.patch
23         rm -rf doc/programming/cvs || die
24 }
25
26 src_compile() {
27         tc-export CC
28         export LNK="${CC}"
29         default
30 }
31
32 src_install() {
33         emake DESTDIR="${D}" install prefix="/usr" docdir="share/doc/${PF}" || die "Unable to install"
34         docinto programming
35         dodoc doc/programming/* *.abc || die "Unable to install documentation"
36 }