media-sound/hydrogen: updated digest for 1.0.0_beta2
[gentoo.git] / media-sound / abcm2ps / abcm2ps-8.14.4.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="Program to convert abc files to Postscript files"
9 HOMEPAGE="https://github.com/leesavide/abcm2ps"
10 SRC_URI="https://github.com/leesavide/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ~ppc x86"
15 IUSE="examples pango"
16
17 BDEPEND="virtual/pkgconfig"
18 DEPEND="
19         pango? (
20                 media-libs/freetype:2
21                 x11-libs/pango
22         )"
23 RDEPEND="${DEPEND}"
24
25 src_configure() {
26         econf \
27                 --enable-a4 \
28                 --enable-deco-is-roll \
29                 $(use_enable pango)
30 }
31
32 src_compile() {
33         emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
34 }
35
36 src_install() {
37         dobin abcm2ps
38
39         insinto /usr/share/${PN}
40         doins *.fmt
41
42         dodoc README.md
43
44         if use examples ; then
45                 docinto examples
46                 dodoc sample*.*
47                 docompress -x /usr/share/doc/${PF}/examples
48         fi
49 }