media-sound/hydrogen: updated digest for 1.0.0_beta2
[gentoo.git] / media-sound / a2jmidid / a2jmidid-9.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit meson
7
8 DESCRIPTION="Daemon for exposing legacy ALSA sequencer applications in JACK MIDI system"
9 HOMEPAGE="https://github.com/linuxaudio/a2jmidid"
10 SRC_URI="https://github.com/linuxaudio/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15 IUSE="dbus"
16
17 BDEPEND="
18         virtual/pkgconfig
19 "
20 CDEPEND="
21         media-libs/alsa-lib
22         virtual/jack
23         dbus? ( sys-apps/dbus )
24 "
25 RDEPEND="${CDEPEND}"
26 DEPEND="${RDEPEND}"
27
28 DOCS=( AUTHORS.rst CHANGELOG.rst README.rst internals.txt )
29
30 src_configure() {
31         local emasonargs=(
32                 -Ddisable-dbus=$(usex dbus false true)
33         )
34
35         meson_src_configure
36 }