Merge remote-tracking branch 'github/pr/608'.
[gentoo.git] / media-radio / xastir / xastir-2.0.4.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=4
6 inherit autotools eutils flag-o-matic toolchain-funcs
7
8 DESCRIPTION="X Amateur Station Tracking and Information Reporting"
9 HOMEPAGE="http://xastir.sourceforge.net/"
10 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15 IUSE="festival gdal geotiff graphicsmagick"
16
17 DEPEND=">=x11-libs/motif-2.3:0
18         x11-libs/libXt
19         x11-libs/libX11
20         x11-libs/libXpm
21         x11-apps/xfontsel
22         dev-libs/libpcre
23         net-misc/curl
24         sys-libs/db
25         sci-libs/shapelib
26         !graphicsmagick? ( media-gfx/imagemagick[-hdri,-q32] )
27         graphicsmagick? ( media-gfx/graphicsmagick[-q32] )
28         geotiff? ( sci-libs/proj
29                 sci-libs/libgeotiff
30                 media-libs/tiff )
31         gdal? ( sci-libs/gdal )
32         festival? ( app-accessibility/festival )"
33 RDEPEND="${DEPEND}"
34
35 src_prepare() {
36         # fix script location (bug #407185)
37         epatch "${FILESDIR}"/${P}-scripts.diff
38
39         # fix __FORTIFY_SOURCE warning (bug #337365)
40         epatch  "${FILESDIR}"/${P}-fortify.diff
41
42         # do not use builtin shapelib if sci-libs/shapelib is not installed
43         # instead build without shapelib support (bug #430704)
44         epatch "${FILESDIR}"/${P}-no-builtin-shapelib.diff
45
46         # do not filter duplicate flags (see bug 411095)
47         epatch "${FILESDIR}"/${PN}-2.0.0-dont-filter-flags.diff
48
49         # fix deprectated AM_CONFIG_HEADER macro
50         sed -i -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" configure.ac || die
51
52         eautoreconf
53 }
54
55 src_configure() {
56         # provide include path to GraphicsMagic for configure stage
57         use graphicsmagick && append-cflags -I/usr/include/GraphicsMagick
58         econf --with-pcre \
59                 --with-shapelib \
60                 --with-dbfawk \
61                 --without-ax25 \
62                 --without-gpsman \
63                 $(use_with !graphicsmagick imagemagick) \
64                 $(use_with graphicsmagick) \
65                 $(use_with geotiff libproj) \
66                 $(use_with geotiff) \
67                 $(use_with gdal) \
68                 $(use_with festival)
69 }
70
71 src_compile() {
72         emake AR="$(tc-getAR)"
73 }
74
75 src_install() {
76         emake DESTDIR="${D}" install
77
78         rm -rf "${D}"/usr/share/doc/${PN}
79         dodoc AUTHORS ChangeLog FAQ README README.Contributing \
80                 README.Getting-Started README.MAPS
81 }
82
83 pkg_postinst() {
84         elog "Kernel mode AX.25 and GPSman library not supported."
85         elog
86         elog "Remember you have to be root to add addditional scripts,"
87         elog "maps and other configuration data under /usr/share/xastir."
88 }