media-radio/flrig: x86 stable wrt bug #700354
[gentoo.git] / media-radio / qrq / qrq-0.3.3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="7"
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="Yet another CW trainer for Linux/Unix"
9 HOMEPAGE="http://fkurz.net/ham/qrq.html"
10 SRC_URI="http://fkurz.net/ham/${PN}/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15 IUSE="pulseaudio"
16
17 DEPEND="sys-libs/ncurses:=
18         pulseaudio? ( media-sound/pulseaudio )"
19 RDEPEND="${DEPEND}"
20
21 PATCHES=( "${FILESDIR}/${PN}-0.3.2-tinfo.patch" )
22
23 src_prepare() {
24         # avoid prestripping of 'qrq' binary
25         sed -i -e "s/install -s -m/install -m/" Makefile || die
26         sed -i -e "s/CC=gcc/CC=$(tc-getCC)/" Makefile || die
27         default
28 }
29
30 src_compile() {
31         CONF="USE_PA=NO USE_OSS=YES"
32         if use pulseaudio; then
33                 CONF="USE_PA=YES USE_OSS=NO"
34         fi
35         emake $CONF
36 }
37
38 src_install() {
39         emake $CONF DESTDIR="${D}/usr" install
40         dodoc AUTHORS ChangeLog README
41 }