dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / media-plugins / vdr-freecell / vdr-freecell-0.0.2-r4.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit vdr-plugin-2
7
8 DESCRIPTION="VDR plugin: play 'Freecell' on the On Screen Display"
9 HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
10 SRC_URI="http://vdr.websitec.de/download/${PN}/${P}.tgz"
11
12 SLOT="0"
13 LICENSE="GPL-2"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 DEPEND="media-video/vdr"
18
19 src_prepare() {
20         vdr-plugin-2_src_prepare
21
22         sed -e "s:RegisterI18n://RegisterI18n:" -i freecell.c || die
23
24         eapply -p2 "${FILESDIR}/gcc-3.4.patch"
25         eapply "${FILESDIR}/${P}-gentoo.diff"
26         eapply "${FILESDIR}/${P}_vdr-1.5.4-compile.diff"
27         eapply "${FILESDIR}/${P}_compilefix.patch"
28 }
29
30 src_install() {
31         vdr-plugin-2_src_install
32
33         insopts -m0644 -ovdr -gvdr
34         insinto /usr/share/vdr/freecell
35         doins "${S}/${VDRPLUGIN}"/*
36 }