sys-libs/libnih: stable 1.0.3-r4 for hppa, bug #724174
[gentoo.git] / media-plugins / vdr-freecell / vdr-freecell-0.0.2-r3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit vdr-plugin-2
7
8 DESCRIPTION="VDR plugin: play 'Freecell' on the On Screen Display"
9 HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
10 SRC_URI="http://vdr.websitec.de/download/${PN}/${P}.tgz"
11
12 SLOT="0"
13 LICENSE="GPL-2"
14 KEYWORDS="amd64 x86"
15 IUSE=""
16
17 DEPEND=">=media-video/vdr-2"
18
19 PATCHES=("${FILESDIR}/${PN}-time_ms.diff"
20                 "${FILESDIR}/gcc-3.4.patch"
21                 "${FILESDIR}/${P}-gentoo.diff"
22                 "${FILESDIR}/${P}_vdr-1.5.4-compile.diff")
23
24 src_prepare() {
25         vdr-plugin-2_src_prepare
26
27         sed -e "s:RegisterI18n://RegisterI18n:" -i freecell.c || die
28 }
29
30 src_install() {
31         vdr-plugin-2_src_install
32
33         insopts -m0644 -ovdr -gvdr
34         insinto /usr/share/vdr/freecell
35         doins "${S}/${VDRPLUGIN}"/*
36 }