media-plugins/gst-plugins-libav: Version bump, 1.16.2
[gentoo.git] / media-plugins / vdr-dvbhddevice / vdr-dvbhddevice-2.1.3_p20140115.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit vdr-plugin-2
7
8 HG_REVISION="60c58ae453d0"
9 HG_REVISION_DATE="20140115"
10
11 DESCRIPTION="VDR Plugin: output device for the 'Full Featured' TechnoTrend
12 S2-6400 DVB Card"
13 HOMEPAGE="https://bitbucket.org/powARman/dvbhddevice"
14 SRC_URI="https://bitbucket.org/powARman/dvbhddevice/get/${HG_REVISION}.tar.gz
15 -> dvbhddevice-2.1.3_p${HG_REVISION_DATE}.tar.gz"
16
17 KEYWORDS="amd64 x86"
18 SLOT="0"
19 LICENSE="GPL-2"
20 IUSE=""
21
22 DEPEND=">=media-video/vdr-1.7.39"
23 RDEPEND="${DEPEND}"
24
25 S="${WORKDIR}/dvbhddevice-${HG_REVISION}"
26
27 src_prepare() {
28         vdr-plugin-2_src_prepare
29
30         fix_vdr_libsi_include dvbhdffdevice.c
31 }
32
33 src_install() {
34         vdr-plugin-2_src_install
35
36         doheader dvbhdffdevice.h hdffcmd.h
37
38         insinto /usr/include/libhdffcmd
39         doins libhdffcmd/*.h
40 }