dev-qt/qttest: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / media-plugins / vdr-atscepg / vdr-atscepg-0.3.0-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit vdr-plugin-2
7
8 DESCRIPTION="VDR plugin: receive schedule and event information from ATSC broadcasts"
9 HOMEPAGE="http://www.fepg.org/atscepg.html"
10 SRC_URI="http://www.fepg.org/files/${P}.tgz
11                 mirror://gentoo/atscepg-${PV}_vdr-1.7.13.tbz
12                 https://dev.gentoo.org/~hd_brummy/distfiles/atscepg-${PV}_vdr-1.7.13.tbz"
13
14 SLOT="0"
15 LICENSE="GPL-2"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 DEPEND=">=media-video/vdr-2"
20
21 RDEPEND="${DEPEND}"
22
23 src_configure() {
24         # disabled gcc -std=c++11,
25         # plugin is dead on upstream since 2010, there is no fixing available
26         filter-flags -std=c++11
27 }
28
29 src_prepare() {
30         vdr-plugin-2_src_prepare
31
32         eapply "${WORKDIR}/atscepg-${PV}_vdr-1.7.13.diff"
33
34         eapply "${FILESDIR}/${P}_gcc6.patch"
35
36         fix_vdr_libsi_include tables.cpp filter.cpp scanner.cpp
37 }