Use https by default
[gentoo.git] / media-plugins / vdr-atscepg / vdr-atscepg-0.3.0-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit vdr-plugin-2
8
9 DESCRIPTION="VDR plugin: receive schedule and event information from ATSC broadcasts"
10 HOMEPAGE="http://www.fepg.org/atscepg.html"
11 SRC_URI="http://www.fepg.org/files/${P}.tgz
12                 mirror://gentoo/atscepg-${PV}_vdr-1.7.13.tbz
13                 https://dev.gentoo.org/~hd_brummy/distfiles/atscepg-${PV}_vdr-1.7.13.tbz"
14
15 SLOT="0"
16 LICENSE="GPL-2"
17 KEYWORDS="~amd64 ~x86"
18 IUSE=""
19
20 DEPEND=">=media-video/vdr-2"
21
22 RDEPEND="${DEPEND}"
23
24 src_configure() {
25         # disabled gcc -std=c++11,
26         # plugin is dead on upstream since 2010, there is no fixing available
27         filter-flags -std=c++11
28 }
29
30 src_prepare() {
31         vdr-plugin-2_src_prepare
32
33         epatch "${WORKDIR}/atscepg-${PV}_vdr-1.7.13.diff"
34
35         fix_vdr_libsi_include tables.cpp filter.cpp scanner.cpp
36 }