dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / media-plugins / swh-lv2 / swh-lv2-1.0.16.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit toolchain-funcs
6
7 DESCRIPTION="Large collection of LV2 audio plugins/effects"
8 HOMEPAGE="http://plugin.org.uk/"
9 SRC_URI="https://github.com/swh/lv2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="amd64 x86"
14 IUSE=""
15
16 RDEPEND="sci-libs/fftw:3.0"
17 DEPEND="${RDEPEND}
18         dev-libs/libxslt
19         virtual/pkgconfig"
20
21 S="${WORKDIR}/lv2-${PV}"
22
23 src_prepare() {
24         sed -e 's:-O3 -fomit-frame-pointer -fstrength-reduce -funroll-loops::g' \
25                 -i Makefile || die
26         default
27 }
28
29 src_compile() {
30         emake CC=$(tc-getCC)
31 }
32
33 src_install() {
34         emake INSTALL_DIR="${D}/usr/$(get_libdir)/lv2" install-system
35         dodoc README
36 }