media-plugins/imlib2_loaders: drop to m-n
[gentoo.git] / media-plugins / kodi-peripheral-steamcontroller / kodi-peripheral-steamcontroller-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit cmake kodi-addon
7
8 DESCRIPTION="Steam controller driver for Kodi"
9 HOMEPAGE="https://github.com/kodi-game/peripheral.steamcontroller"
10 SRC_URI=""
11
12 case ${PV} in
13 9999)
14         SRC_URI=""
15         EGIT_REPO_URI="https://github.com/kodi-game/peripheral.steamcontroller.git"
16         inherit git-r3
17         ;;
18 *)
19         KEYWORDS="~amd64 ~x86"
20         SRC_URI="https://github.com/kodi-game/peripheral.steamcontroller/archive/v${PV}.tar.gz -> ${P}.tar.gz"
21         S="${WORKDIR}/peripheral.steamcontroller-${PV}"
22         ;;
23 esac
24
25 LICENSE="GPL-2"
26 SLOT="0"
27 IUSE=""
28
29 DEPEND="
30         ~media-tv/kodi-9999
31         ~media-libs/kodi-platform-9999
32         =dev-libs/libplatform-2*
33         virtual/libusb:1
34         "
35 RDEPEND="
36         ${DEPEND}
37         "