media-plugins/kodi-audioencoder-lame: use HTTPS for GitHub
[gentoo.git] / media-plugins / kodi-audioencoder-lame / kodi-audioencoder-lame-1.2.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit cmake-utils kodi-addon
7
8 DESCRIPTION="Lame MP3 encoder addon for Kodi"
9 HOMEPAGE="https://github.com/xbmc/audioencoder.lame"
10 SRC_URI=""
11
12 case ${PV} in
13 9999)
14         SRC_URI=""
15         EGIT_REPO_URI="https://github.com/xbmc/audioencoder.lame.git"
16         inherit git-r3
17         ;;
18 *)
19         KEYWORDS="~amd64 ~x86"
20         SRC_URI="https://github.com/xbmc/audioencoder.lame/archive/v${PV}.tar.gz -> ${P}.tar.gz"
21         S="${WORKDIR}/audioencoder.lame-${PV}"
22         ;;
23 esac
24
25 LICENSE="GPL-2"
26 SLOT="0"
27 IUSE=""
28
29 DEPEND="
30         media-tv/kodi
31         media-sound/lame
32         "
33
34 RDEPEND="
35         ${DEPEND}
36         "