Merge remote-tracking branch 'github/pr/3411'
[gentoo.git] / media-plugins / gst-plugins-v4l2 / gst-plugins-v4l2-1.6.3.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6 GST_ORG_MODULE=gst-plugins-good
7
8 inherit gstreamer
9
10 DESCRIPION="plugin to allow capture from video4linux2 devices"
11 KEYWORDS="alpha amd64 arm hppa ~ia64 ppc ppc64 ~sparc x86"
12 IUSE="udev"
13
14 RDEPEND="
15         >=media-libs/libv4l-0.9.5[${MULTILIB_USEDEP}]
16         >=media-libs/gst-plugins-base-1.4:1.0[X,${MULTILIB_USEDEP}]
17         udev? ( >=virtual/libgudev-208:=[${MULTILIB_USEDEP}] )
18 "
19 DEPEND="${RDEPEND}
20         virtual/os-headers
21 "
22
23 GST_PLUGINS_BUILD="gst_v4l2"
24
25 multilib_src_configure() {
26         gstreamer_multilib_src_configure \
27                 --with-libv4l2 \
28                 $(use_with udev gudev)
29 }