media-{libs,plugins}/gst-plugins-*: Drop sparc stable keywords
[gentoo.git] / media-plugins / gst-plugins-v4l2 / gst-plugins-v4l2-1.10.3.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 GST_ORG_MODULE=gst-plugins-good
6
7 inherit gstreamer
8
9 DESCRIPION="V4L2 source/sink plugin for GStreamer"
10 KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~sparc x86"
11 IUSE="udev"
12
13 RDEPEND="
14         >=media-libs/libv4l-0.9.5[${MULTILIB_USEDEP}]
15         >=media-libs/gst-plugins-base-${PV}:${SLOT}[X,${MULTILIB_USEDEP}]
16         udev? ( >=virtual/libgudev-208:=[${MULTILIB_USEDEP}] )
17 "
18 DEPEND="${RDEPEND}
19         virtual/os-headers
20 "
21
22 GST_PLUGINS_BUILD="gst_v4l2"
23
24 multilib_src_configure() {
25         gstreamer_multilib_src_configure \
26                 --with-libv4l2 \
27                 $(use_with udev gudev)
28 }