media-plugins/gst-plugins-opencv: raise opencv minimum to ensure testing
[gentoo.git] / media-plugins / gst-plugins-opencv / gst-plugins-opencv-1.16.2-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 GST_ORG_MODULE=gst-plugins-bad
6
7 inherit gstreamer
8
9 DESCRIPTION="OpenCV elements for GStreamer"
10 KEYWORDS="~amd64 ~x86"
11 IUSE=""
12
13 # >=opencv-4.1.2-r3 to help testing removal of older being fine
14 RDEPEND="
15         >=media-libs/opencv-4.1.2-r3:=[contrib,${MULTILIB_USEDEP}]
16         <media-libs/opencv-4.2
17 "
18 DEPEND="${RDEPEND}"
19
20 # Ships the opencv separate helper library as part of gst-plugins-opencv as it depends on OpenCV
21 multilib_src_compile() {
22         emake -C gst-libs/gst/opencv
23         gstreamer_multilib_src_compile
24 }
25
26 multilib_src_install() {
27         emake -C gst-libs/gst/opencv DESTDIR="${D}" install
28         gstreamer_multilib_src_install
29 }