media-plugins/vdr-skinelchi: compile fix for not declared min/max
[gentoo.git] / media-plugins / gst-plugins-gtk / gst-plugins-gtk-1.14.5.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 GST_ORG_MODULE=gst-plugins-good
6
7 inherit gstreamer
8
9 DESCRIPTION="Video sink plugin for GStreamer that renders to a GtkWidget"
10 KEYWORDS="alpha amd64 arm arm64 ~hppa ia64 ~mips ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
11 IUSE="+egl gles2 +opengl wayland +X" # Keep default IUSE mirrored with gst-plugins-base
12 # egl, wayland and X only matters if gst-plugins-bad is build with USE=opengl and/or USE=gles2
13 # We mirror egl/gles2/opengl/wayland/X due to automagic detection from gstreamer-gl.pc variables;
14 # we don't care about matching egl/wayland/X if both opengl and gles2 are disabled here and on
15 # gst-plugins-base, but no way to express that.
16
17 # We only need gtk+ matching backend flags when GL is enabled
18 GL_DEPS="
19         >=x11-libs/gtk+-3.15:3[X?,wayland?,${MULTILIB_USEDEP}]
20 "
21 RDEPEND="
22         >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP},egl=,gles2=,opengl=,wayland=,X=]
23         >=x11-libs/gtk+-3.15:3[${MULTILIB_USEDEP}]
24         gles2? ( ${GL_DEPS} )
25         opengl? ( ${GL_DEPS} )
26
27         !<media-libs/gst-plugins-bad-1.13.1:1.0
28 "
29 DEPEND="${RDEPEND}"
30
31 GST_PLUGINS_BUILD="gtk3"