media-plugins/gst-plugins-vaapi: bump to 1.14.1, rework OpenGL handling
[gentoo.git] / media-plugins / gst-plugins-gconf / gst-plugins-gconf-0.10.31-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 GST_ORG_MODULE=gst-plugins-good
7 inherit gnome2-utils gstreamer
8
9 DESCRIPTION="GStreamer plugin for wrapping GConf audio/video settings"
10 KEYWORDS="alpha amd64 arm ia64 ppc ppc64 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
11 IUSE=""
12
13 RDEPEND=">=gnome-base/gconf-2.32.4-r1[${MULTILIB_USEDEP}]"
14 DEPEND="${RDEPEND}"
15
16 GST_PLUGINS_BUILD="gconf gconftool"
17
18 multilib_src_configure() {
19         gstreamer_multilib_src_configure \
20                 --disable-schemas-install
21 }
22
23 multilib_src_compile() {
24         gstreamer_multilib_src_compile
25
26         if multilib_is_native_abi; then
27                 emake -C gconf
28         fi
29 }
30
31 multilib_src_install() {
32         gstreamer_multilib_src_install
33
34         if multilib_is_native_abi; then
35                 emake -C gconf DESTDIR="${D}" install
36         fi
37 }
38
39 pkg_preinst() {
40         gnome2_gconf_savelist
41 }
42
43 pkg_postinst() {
44         gnome2_gconf_install
45 }