Revert DOCTYPE SYSTEM https changes in metadata.xml
[gentoo.git] / media-plugins / audacious-plugins / audacious-plugins-3.5.1.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit eutils
7
8 MY_P="${P/_/-}"
9 S="${WORKDIR}/${MY_P}"
10 DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
11 HOMEPAGE="http://audacious-media-player.org/"
12 SRC_URI="http://distfiles.audacious-media-player.org/${MY_P}.tar.bz2"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux"
17 IUSE="aac adplug alsa bs2b cdda cue ffmpeg flac fluidsynth gnome jack
18 lame libnotify libsamplerate lirc midi mms mp3 nls pulseaudio scrobbler sdl sid sndfile vorbis wavpack"
19
20 RDEPEND="app-arch/unzip
21         >=dev-libs/dbus-glib-0.60
22         dev-libs/libxml2:2
23         media-libs/libmodplug
24         ~media-sound/audacious-3.5.1
25         >=net-libs/neon-0.26.4
26         x11-libs/gtk+:3
27         ( || ( >=dev-libs/glib-2.32.2[utils] dev-util/gdbus-codegen ) )
28         aac? ( >=media-libs/faad2-2.7 )
29         adplug? ( >=dev-cpp/libbinio-1.4 )
30         alsa? ( >=media-libs/alsa-lib-1.0.16 )
31         bs2b? ( media-libs/libbs2b )
32         cdda? ( >=media-libs/libcddb-1.2.1
33                 dev-libs/libcdio-paranoia )
34         cue? ( media-libs/libcue )
35         ffmpeg? ( >=virtual/ffmpeg-0.7.3 )
36         flac? ( >=media-libs/libvorbis-1.0
37                 >=media-libs/flac-1.2.1-r1 )
38         fluidsynth? ( media-sound/fluidsynth )
39         jack? ( >=media-libs/bio2jack-0.4
40                 media-sound/jack-audio-connection-kit )
41         lame? ( media-sound/lame )
42         libnotify? ( x11-libs/libnotify )
43         libsamplerate? ( media-libs/libsamplerate )
44         lirc? ( app-misc/lirc )
45         mms? ( >=media-libs/libmms-0.3 )
46         mp3? ( >=media-sound/mpg123-1.12.1 )
47         pulseaudio? ( >=media-sound/pulseaudio-0.9.3 )
48         scrobbler? ( net-misc/curl )
49         sdl? ( media-libs/libsdl[sound] )
50         sid? ( >=media-libs/libsidplayfp-1.0.0 )
51         sndfile? ( >=media-libs/libsndfile-1.0.17-r1 )
52         vorbis? ( >=media-libs/libvorbis-1.2.0
53                   >=media-libs/libogg-1.1.3 )
54         wavpack? ( >=media-sound/wavpack-4.50.1-r1 )"
55
56 DEPEND="${RDEPEND}
57         nls? ( dev-util/intltool )
58         virtual/pkgconfig"
59
60 DOCS="AUTHORS"
61
62 mp3_warning() {
63         if ! use mp3 ; then
64                 ewarn "MP3 support is optional, you may want to enable the mp3 USE-flag"
65         fi
66 }
67
68 src_prepare() {
69         has_version "<dev-libs/glib-2.32" && \
70                 cd "${S}"/src/mpris2 && \
71                 gdbus-codegen --interface-prefix org.mpris. \
72                         --c-namespace Mpris --generate-c-code object-core mpris2.xml && \
73                 gdbus-codegen --interface-prefix org.mpris. \
74                         --c-namespace Mpris \
75                         --generate-c-code object-player mpris2-player.xml && \
76                 cd "${S}"
77 }
78
79 src_configure() {
80         mp3_warning
81
82         if use ffmpeg && has_version media-video/ffmpeg ; then
83                 ffmpeg="--with-ffmpeg=ffmpeg"
84         elif use ffmpeg && has_version media-video/libav ; then
85                 ffmpeg="--with-ffmpeg=libav"
86         else
87                 ffmpeg="--with-ffmpeg=none"
88         fi
89
90         econf \
91                 ${ffmpeg} \
92                 --enable-modplug \
93                 --disable-soxr \
94                 --enable-neon \
95                 $(use_enable adplug) \
96                 $(use_enable aac) \
97                 $(use_enable alsa) \
98                 $(use_enable bs2b) \
99                 $(use_enable cdda cdaudio) \
100                 $(use_enable cue) \
101                 $(use_enable flac flacng) \
102                 $(use_enable fluidsynth amidiplug) \
103                 $(use_enable flac filewriter_flac) \
104                 $(use_enable jack) \
105                 $(use_enable gnome gnomeshortcuts) \
106                 $(use_enable lame filewriter_mp3) \
107                 $(use_enable libnotify notify) \
108                 $(use_enable libsamplerate resample) \
109                 $(use_enable lirc) \
110                 $(use_enable mms) \
111                 $(use_enable mp3) \
112                 $(use_enable midi amidiplug) \
113                 $(use_enable nls) \
114                 $(use_enable pulseaudio pulse) \
115                 $(use_enable scrobbler scrobbler2) \
116                 $(use_enable sdl sdlout) \
117                 $(use_enable sid) \
118                 $(use_enable sndfile) \
119                 $(use_enable vorbis) \
120                 $(use_enable wavpack)
121 }