dev-python/cmd2: update HOMEPAGE
[gentoo.git] / media-plugins / audacious-plugins / audacious-plugins-3.4.1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit eutils
6
7 MY_P="${P/_/-}"
8 S="${WORKDIR}/${MY_P}"
9 DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
10 HOMEPAGE="http://audacious-media-player.org/"
11 SRC_URI="http://distfiles.audacious-media-player.org/${MY_P}.tar.bz2"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="alpha amd64 ~arm hppa ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
16 IUSE="aac adplug alsa bs2b cdda cue ffmpeg flac fluidsynth gnome ipv6 jack
17 lame libnotify libsamplerate lirc midi mms mp3 nls pulseaudio scrobbler sdl sid sndfile vorbis wavpack"
18
19 RDEPEND="app-arch/unzip
20         >=dev-libs/dbus-glib-0.60
21         dev-libs/libxml2:2
22         media-libs/libmodplug
23         ~media-sound/audacious-3.4.1
24         >=net-libs/neon-0.26.4
25         x11-libs/gtk+:3
26         ( || ( >=dev-libs/glib-2.32.2 dev-util/gdbus-codegen ) )
27         aac? ( >=media-libs/faad2-2.7 )
28         adplug? ( >=dev-cpp/libbinio-1.4 )
29         alsa? ( >=media-libs/alsa-lib-1.0.16 )
30         bs2b? ( media-libs/libbs2b )
31         cdda? ( >=media-libs/libcddb-1.2.1
32                 dev-libs/libcdio-paranoia )
33         cue? ( media-libs/libcue )
34         ffmpeg? ( >=virtual/ffmpeg-0.7.3 )
35         flac? ( >=media-libs/libvorbis-1.0
36                 >=media-libs/flac-1.2.1-r1 )
37         fluidsynth? ( media-sound/fluidsynth )
38         jack? ( >=media-libs/bio2jack-0.4
39                 media-sound/jack-audio-connection-kit )
40         lame? ( media-sound/lame )
41         libnotify? ( x11-libs/libnotify )
42         libsamplerate? ( media-libs/libsamplerate )
43         lirc? ( app-misc/lirc )
44         mms? ( >=media-libs/libmms-0.3 )
45         mp3? ( >=media-sound/mpg123-1.12.1 )
46         pulseaudio? ( >=media-sound/pulseaudio-0.9.3 )
47         scrobbler? ( net-misc/curl )
48         sdl? ( media-libs/libsdl[sound] )
49         sid? ( >=media-libs/libsidplayfp-1.0.0 )
50         sndfile? ( >=media-libs/libsndfile-1.0.17-r1 )
51         vorbis? ( >=media-libs/libvorbis-1.2.0
52                   >=media-libs/libogg-1.1.3 )
53         wavpack? ( >=media-sound/wavpack-4.50.1-r1 )"
54
55 DEPEND="${RDEPEND}
56         nls? ( dev-util/intltool )
57         virtual/pkgconfig"
58
59 DOCS="AUTHORS"
60
61 mp3_warning() {
62         if ! use mp3 ; then
63                 ewarn "MP3 support is optional, you may want to enable the mp3 USE-flag"
64         fi
65 }
66
67 src_prepare() {
68         has_version "<dev-libs/glib-2.32" && \
69                 cd "${S}"/src/mpris2 && \
70                 gdbus-codegen --interface-prefix org.mpris. \
71                         --c-namespace Mpris --generate-c-code object-core mpris2.xml && \
72                 gdbus-codegen --interface-prefix org.mpris. \
73                         --c-namespace Mpris \
74                         --generate-c-code object-player mpris2-player.xml && \
75                 cd "${S}"
76 }
77
78 src_configure() {
79         mp3_warning
80
81         econf \
82                 --enable-modplug \
83                 --disable-soxr \
84                 --enable-neon \
85                 $(use_enable adplug) \
86                 $(use_enable aac) \
87                 $(use_enable alsa) \
88                 $(use_enable alsa amidiplug-alsa) \
89                 $(use_enable bs2b) \
90                 $(use_enable cdda cdaudio) \
91                 $(use_enable cue) \
92                 $(use_enable ffmpeg ffaudio) \
93                 $(use_enable flac flacng) \
94                 $(use_enable fluidsynth amidiplug-flsyn) \
95                 $(use_enable flac filewriter_flac) \
96                 $(use_enable ipv6) \
97                 $(use_enable jack) \
98                 $(use_enable gnome gnomeshortcuts) \
99                 $(use_enable lame filewriter_mp3) \
100                 $(use_enable libnotify notify) \
101                 $(use_enable libsamplerate resample) \
102                 $(use_enable lirc) \
103                 $(use_enable mms) \
104                 $(use_enable mp3) \
105                 $(use_enable midi amidiplug) \
106                 $(use_enable nls) \
107                 $(use_enable pulseaudio pulse) \
108                 $(use_enable scrobbler) \
109                 $(use_enable sdl sdlout) \
110                 $(use_enable sid) \
111                 $(use_enable sndfile) \
112                 $(use_enable vorbis) \
113                 $(use_enable wavpack)
114 }