media-libs/libquvi-scripts: drop to ~hppa
[gentoo.git] / media-libs / webrtc-audio-processing / webrtc-audio-processing-0.3.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit autotools multilib-minimal
7
8 DESCRIPTION="AudioProcessing library from the webrtc.org code base"
9 HOMEPAGE="https://www.freedesktop.org/software/pulseaudio/webrtc-audio-processing/"
10 SRC_URI="https://freedesktop.org/software/pulseaudio/${PN}/${P}.tar.xz"
11
12 LICENSE="BSD"
13 SLOT="0"
14 KEYWORDS="amd64 x86 ~amd64-linux"
15 IUSE="static-libs"
16
17 DOCS=( AUTHORS NEWS README.md )
18
19 PATCHES=(
20         "${FILESDIR}"/${PN}-0.3-proper_detection_cxxabi_execinfo.patch
21 )
22
23 src_prepare() {
24         eautoreconf
25         default
26 }
27
28 multilib_src_configure() {
29         ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
30 }
31
32 multilib_src_install_all() {
33         find "${ED}" -type f -name "*.la" -delete || die
34 }