media-libs/mesa: Add Python 3.8 support
[gentoo.git] / media-libs / waffle / waffle-9999.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 if [[ ${PV} = *9999* ]]; then
7         EGIT_REPO_URI="https://gitlab.freedesktop.org/mesa/${PN}"
8         GIT_ECLASS="git-r3"
9 else
10         SRC_URI="http://www.waffle-gl.org/files/release/${P}/${P}.tar.xz"
11         KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
12 fi
13 inherit meson multilib-minimal ${GIT_ECLASS}
14
15 DESCRIPTION="Library that allows selection of GL API and of window system at runtime"
16 HOMEPAGE="http://www.waffle-gl.org/ https://gitlab.freedesktop.org/mesa/waffle"
17
18 LICENSE="BSD-2"
19 SLOT="0"
20 IUSE="doc egl gbm test wayland X"
21 RESTRICT="test" # gl_basic tests don't work when run from portage
22
23 RDEPEND="
24         >=media-libs/mesa-9.1.6[egl?,gbm?,${MULTILIB_USEDEP}]
25         >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}]
26         >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
27         >=x11-libs/libxcb-1.9.1[${MULTILIB_USEDEP}]
28         gbm? ( >=virtual/libudev-208:=[${MULTILIB_USEDEP}] )
29         wayland? ( >=dev-libs/wayland-1.0.6[${MULTILIB_USEDEP}] )
30 "
31 DEPEND="${RDEPEND}
32         >=x11-base/xcb-proto-1.8-r3[${MULTILIB_USEDEP}]
33         doc? (
34                 dev-libs/libxslt
35                 app-text/docbook-xml-dtd:4.2
36         )
37 "
38
39 src_unpack() {
40         default
41         [[ $PV = 9999* ]] && git-r3_src_unpack
42 }
43
44 multilib_src_configure() {
45         local emesonargs=(
46                 $(meson_feature X glx)
47                 $(meson_feature wayland)
48                 $(meson_feature X x11_egl)
49                 $(meson_feature gbm)
50                 $(meson_feature egl surfaceless_egl)
51                 $(meson_use test build-tests)
52                 $(meson_use doc build-manpages)
53         )
54         meson_src_configure
55 }
56
57 multilib_src_compile() {
58         meson_src_compile
59 }
60
61 multilib_src_test() {
62         meson_src_test
63 }
64
65 multilib_src_install() {
66         meson_src_install
67
68         rm -rf "${D}"/usr/share/doc/waffle1
69 }