Merge branch 'perl-eapi6' - EAPI=6 support for perl-module.eclass
[gentoo.git] / media-libs / virglrenderer / virglrenderer-9999.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6
7 inherit autotools
8
9 if [[ ${PV} == "9999" ]] ; then
10         EGIT_REPO_URI="git://people.freedesktop.org/~airlied/virglrenderer"
11         inherit git-2
12 else
13         SRC_URI="mirror://gentoo/${P}.tar.xz"
14         KEYWORDS="~amd64 ~x86"
15 fi
16
17 DESCRIPTION="library used implement a virtual 3D GPU used by qemu"
18 HOMEPAGE="https://virgil3d.github.io/"
19
20 LICENSE="MIT"
21 SLOT="0"
22 IUSE="static-libs test"
23
24 RDEPEND=">=x11-libs/libdrm-2.4.50
25         media-libs/libepoxy"
26 # We need autoconf-archive for @CODE_COVERAGE_RULES@. #568624
27 DEPEND="${RDEPEND}
28         sys-devel/autoconf-archive
29         >=x11-misc/util-macros-1.8
30         test? ( >=dev-libs/check-0.9.4 )"
31
32 src_prepare() {
33         [[ -e configure ]] || eautoreconf
34 }
35
36 src_configure() {
37         econf \
38                 $(use_enable static-libs static) \
39                 $(use_enable test tests)
40 }
41
42 src_install() {
43         default
44         find "${ED}"/usr -name 'lib*.la' -delete
45 }