Use https by default
[gentoo.git] / media-libs / smpeg2 / smpeg2-2.0.0-r3.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit eutils toolchain-funcs autotools multilib-minimal
7
8 MY_P=smpeg-${PV}
9 DESCRIPTION="SDL MPEG Player Library"
10 HOMEPAGE="http://icculus.org/smpeg/"
11 SRC_URI="https://dev.gentoo.org/~hasufell/distfiles/${MY_P}.tar.bz2"
12
13 LICENSE="LGPL-2"
14 SLOT="0"
15 KEYWORDS="amd64 x86"
16 IUSE="debug cpu_flags_x86_mmx static-libs"
17
18 DEPEND=">=media-libs/libsdl2-2.0.1-r1[${MULTILIB_USEDEP}]"
19 RDEPEND="${DEPEND}"
20
21 DOCS=( CHANGES README README.SDL_mixer TODO )
22
23 S=${WORKDIR}/${MY_P}
24
25 src_prepare() {
26         epatch "${FILESDIR}"/${P}-smpeg2-config.patch
27
28         # avoid file collision with media-libs/smpeg
29         sed -i \
30                 -e '/plaympeg/d' \
31                 Makefile.am || die
32
33         mv configure.in configure.ac || die
34         AT_M4DIR="/usr/share/aclocal acinclude" eautoreconf
35 }
36
37 multilib_src_configure() {
38         # the debug option is bogus ... all it does is add extra
39         # optimizations if you pass --disable-debug
40         ECONF_SOURCE="${S}" econf \
41                 $(use_enable static-libs static) \
42                 --disable-rpath \
43                 --enable-debug \
44                 --disable-sdltest \
45                 $(use_enable cpu_flags_x86_mmx mmx) \
46                 $(use_enable debug assertions)
47 }
48
49 multilib_src_install_all() {
50         use static-libs || prune_libtool_files
51 }