dev-ruby/sqlite3: add 1.4.2
[gentoo.git] / media-libs / skstream / skstream-0.3.9.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit flag-o-matic
7
8 DESCRIPTION="FreeSockets - Portable C++ classes for IP (sockets) applications"
9 HOMEPAGE="https://www.worldforge.org/"
10 SRC_URI="mirror://sourceforge/worldforge/${P}.tar.bz2"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ppc x86"
15 IUSE="test"
16 RESTRICT="!test? ( test )"
17
18 DEPEND="test? ( dev-util/cppunit )"
19 RDEPEND=""
20
21 PATCHES=( "${FILESDIR}"/${P}-test.patch )
22
23 src_configure() {
24         # bug 651840
25         append-cxxflags -std=c++11
26
27         default
28 }