sys-libs/musl: fix bug #667234
[gentoo.git] / media-libs / sbc / sbc-1.3.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit multilib multilib-minimal
6
7 DESCRIPTION="Audio codec to connect bluetooth HQ audio devices as headphones or loudspeakers"
8 HOMEPAGE="https://git.kernel.org/?p=bluetooth/sbc.git http://www.bluez.org/sbc-10/"
9 SRC_URI="mirror://kernel/linux/bluetooth/${P}.tar.xz"
10
11 LICENSE="GPL-2 LGPL-2.1"
12 SLOT="0"
13 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 sparc x86"
14 IUSE="static-libs"
15
16 # --enable-tester is building src/sbctester but the tarball is missing required
17 # .wav file to execute it
18 RESTRICT="test"
19
20 RDEPEND=""
21 DEPEND="virtual/pkgconfig"
22
23 multilib_src_configure() {
24         ECONF_SOURCE=${S} \
25         econf \
26                 $(use_enable static-libs static) \
27                 --disable-tester
28 }
29
30 multilib_src_install_all() {
31         einstalldocs
32         find "${D}" -name '*.la' -delete || die
33 }