dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / media-libs / raspberrypi-userland-bin / raspberrypi-userland-bin-1.20190709.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="Raspberry Pi userspace tools and libraries"
7 HOMEPAGE="https://github.com/raspberrypi/firmware"
8 MY_P="raspberrypi-firmware-${PV}"
9 SRC_URI="https://github.com/raspberrypi/firmware/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
10
11 LICENSE="BSD GPL-2 raspberrypi-videocore-bin"
12 SLOT="0"
13 KEYWORDS="-* ~arm"
14 IUSE="+hardfp examples"
15
16 RDEPEND="!media-libs/raspberrypi-userland"
17 DEPEND="${DEPEND}"
18
19 S="${WORKDIR}/firmware-${PV}"
20
21 RESTRICT="binchecks"
22
23 src_install() {
24         cd $(usex hardfp hardfp/ "")opt/vc || die
25
26         insinto /opt/vc
27         doins -r include
28         into /opt
29         dobin bin/*
30         insopts -m 0755
31         insinto "/opt/vc/lib"
32         doins -r lib/*
33
34         doenvd "${FILESDIR}"/04${PN}
35
36         if use examples ; then
37                 insopts -m 0644
38                 insinto /usr/share/doc/${PF}/examples
39                 doins -r src/hello_pi
40         fi
41 }