*/*: Bump copyright on files touched this year
[gentoo.git] / media-libs / portaudio / portaudio-19.06.00-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit ltprune multilib-minimal
6
7 DESCRIPTION="A free, cross-platform, open-source, audio I/O library"
8 HOMEPAGE="http://www.portaudio.com/"
9 SRC_URI="http://www.portaudio.com/archives/pa_stable_v190600_20161030.tgz"
10
11 LICENSE="MIT"
12 SLOT="0"
13 KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-linux ~x86-linux"
14 IUSE="alsa +cxx debug doc jack oss static-libs"
15
16 RDEPEND="alsa? ( >=media-libs/alsa-lib-1.0.27.2[${MULTILIB_USEDEP}] )
17         jack? ( virtual/jack[${MULTILIB_USEDEP}] )"
18 DEPEND="${RDEPEND}
19         doc? ( app-doc/doxygen )
20         virtual/pkgconfig"
21
22 S=${WORKDIR}/${PN}
23
24 DOCS=( README.txt )
25
26 multilib_src_configure() {
27         local myeconfargs=(
28                 $(use_enable debug debug-output)
29                 $(use_enable cxx)
30                 $(use_enable static-libs static)
31                 $(use_with alsa)
32                 $(use_with jack)
33                 $(use_with oss)
34         )
35
36         ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
37 }
38
39 multilib_src_compile() {
40         # workaround parallel build issue
41         emake lib/libportaudio.la
42         emake
43 }
44
45 src_compile() {
46         multilib-minimal_src_compile
47
48         if use doc; then
49                 doxygen -u Doxyfile || die
50                 doxygen Doxyfile || die
51         fi
52 }
53
54 multilib_src_install_all() {
55         einstalldocs
56         use doc && dodoc -r doc/html
57         prune_libtool_files
58 }