media-libs/nas: x86 stable (bug #664320)
[gentoo.git] / media-libs / plib / plib-1.8.5-r2.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5 inherit flag-o-matic autotools
6
7 DESCRIPTION="multimedia library used by many games"
8 HOMEPAGE="http://plib.sourceforge.net/"
9 SRC_URI="http://plib.sourceforge.net/dist/${P}.tar.gz"
10
11 LICENSE="LGPL-2"
12 SLOT="0"
13 KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
14
15 DEPEND="virtual/opengl"
16 RDEPEND=${DEPEND}
17
18 PATCHES=(
19         "${FILESDIR}"/${P}-X11-r1.patch
20         "${FILESDIR}"/${P}-CVE-2011-4620.patch
21         "${FILESDIR}"/${P}-CVE-2012-4552.patch
22 )
23
24 src_prepare() {
25         default
26
27         mv configure.in configure.ac || die
28
29         eautoreconf
30
31         # Since plib only provides static libraries, force
32         # building as PIC or plib is useless to amd64/etc...
33         append-flags -fPIC
34 }
35
36 src_install() {
37         DOCS=( AUTHORS ChangeLog KNOWN_BUGS NOTICE README* TODO* )
38
39         default
40 }