media-libs/libpostproc: Remove
[gentoo.git] / media-libs / phat / phat-0.4.1-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit autotools eutils ltprune
7
8 DESCRIPTION="PHAT is a collection of GTK+ widgets geared toward pro-audio apps"
9 HOMEPAGE="https://sourceforge.net/projects/phat.berlios/"
10 SRC_URI="mirror://sourceforge/phat.berlios/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ppc sparc x86"
15 IUSE="debug"
16
17 RDEPEND="x11-libs/gtk+:2
18         x11-libs/libX11
19         gnome-base/libgnomecanvas"
20 DEPEND="${RDEPEND}
21         virtual/pkgconfig
22         dev-util/gtk-doc"
23
24 PATCHES=(
25         "${FILESDIR}/${P}-underlinking.patch"
26 )
27
28 src_prepare() {
29         default
30         eautoreconf
31 }
32
33 src_configure() {
34         econf \
35                 --disable-static \
36                 $(use_enable debug)
37 }
38
39 src_install() {
40         default
41         prune_libtool_files --all
42 }