sys-block/di: Bump to version 4.47.2
[gentoo.git] / media-libs / partio / partio-1.1.0_p20170829.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python{2_7,3_5,3_6} )
6
7 inherit cmake-utils vcs-snapshot python-single-r1
8
9 DESCRIPTION="A library for particle IO and manipulation"
10 HOMEPAGE="https://www.disneyanimation.com/technology/partio.html"
11
12 MY_GIT_COMMIT="2774ef3958da46d9f8a4230ebda9e04b1aa8f4e5"
13 SRC_URI="https://github.com/wdas/${PN}/archive/${MY_GIT_COMMIT}.tar.gz -> ${P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0"
17 KEYWORDS="amd64 x86"
18 IUSE="doc"
19 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
20
21 RDEPEND="${PYTHON_DEPS}
22         media-libs/freeglut
23         virtual/opengl
24         sys-libs/zlib:=
25 "
26
27 DEPEND="${RDEPEND}
28         doc? ( app-doc/doxygen[latex] )
29         dev-lang/swig:*
30 "
31
32 PATCHES=( "${FILESDIR}/${PN}-1.1.0-Rename-partconv.patch" )
33
34 src_prepare() {
35         cmake-utils_src_prepare
36
37         sed -e '/ADD_SUBDIRECTORY (src\/tests)/d' -i CMakeLists.txt || die
38 }
39
40 src_configure() {
41         local mycmakeargs=(
42                 $(cmake-utils_use_find_package doc Doxygen)
43                 -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
44         )
45
46         cmake-utils_src_configure
47 }