x11-themes/gentoo10-backgrounds: Cleanup per bug #85210
[gentoo.git] / media-libs / opusfile / opusfile-0.6.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 DESCRIPTION="A high-level decoding and seeking API for .opus files"
8 HOMEPAGE="http://www.opus-codec.org/"
9 SRC_URI="http://downloads.xiph.org/releases/opus/${P}.tar.gz"
10
11 LICENSE="BSD"
12 SLOT="0"
13 KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86"
14 IUSE="doc fixed-point +float +http static-libs"
15
16 RDEPEND="media-libs/libogg
17         media-libs/opus
18         http? ( dev-libs/openssl:= )"
19
20 DEPEND="${RDEPEND}
21         doc? ( app-doc/doxygen )"
22
23 REQUIRED_USE="^^ ( fixed-point float )"
24
25 src_configure() {
26         econf \
27                 --docdir=/usr/share/doc/${PF} \
28                 $(use_enable doc) \
29                 $(use_enable fixed-point)\
30                 $(use_enable float) \
31                 $(use_enable http) \
32                 $(use_enable static-libs static)
33 }