media-libs/fontconfig: amd64 stable wrt bug #664108
[gentoo.git] / media-libs / libtxc_dxtn / libtxc_dxtn-1.0.1-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit autotools-multilib
7
8 DESCRIPTION="Helper library for S3TC texture (de)compression"
9 HOMEPAGE="https://cgit.freedesktop.org/~mareko/libtxc_dxtn/"
10 SRC_URI="https://people.freedesktop.org/~cbrill/${PN}/${P}.tar.bz2"
11
12 LICENSE="MIT"
13 SLOT="0"
14 KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
15 IUSE=""
16
17 RDEPEND="media-libs/mesa"
18 DEPEND="${RDEPEND}"
19
20 RESTRICT="bindist"
21
22 src_install() {
23         autotools-multilib_src_install
24
25         # libtxc_dxtn is installed as a module (plugin)
26         prune_libtool_files --all
27 }
28
29 pkg_postinst() {
30         ewarn "Depending on where you live, you might need a valid license for s3tc"
31         ewarn "in order to be legally allowed to use the external library."
32         ewarn "Redistribution in binary form might also be problematic."
33         ewarn
34         ewarn "You have been warned. Have a nice day."
35 }