dedef265f14f06bc48def35879aa931bc1b1d8d7
[gentoo.git] / media-libs / libpagemaker / libpagemaker-0.0.4.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 EGIT_REPO_URI="git://gerrit.libreoffice.org/${PN}.git"
7 [[ ${PV} == 9999 ]] && inherit autotools git-r3
8
9 DESCRIPTION="C++ Library that parses the file format of Aldus/Adobe PageMaker documents."
10 HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libpagemaker"
11 [[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
12
13 LICENSE="MPL-2.0"
14 SLOT="0"
15
16 [[ ${PV} == 9999 ]] || \
17 KEYWORDS="amd64 ~arm arm64 ~hppa ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
18 IUSE="debug doc tools"
19
20 RDEPEND="
21         dev-libs/librevenge
22 "
23 DEPEND="${RDEPEND}
24         dev-libs/boost
25         virtual/pkgconfig
26         doc? ( app-doc/doxygen )
27 "
28
29 src_prepare() {
30         default
31         [[ ${PV} == 9999 ]] && eautoreconf
32 }
33
34 src_configure() {
35         econf \
36                 --disable-werror \
37                 $(use_with doc docs) \
38                 $(use_enable tools)
39 }
40
41 src_install() {
42         default
43         find "${D}" -name '*.la' -delete || die
44 }