dev-qt/qttest: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / media-libs / libhdhomerun / libhdhomerun-20190621.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="SiliconDust HDHomeRun Utilties"
9 HOMEPAGE="https://www.silicondust.com/support/linux/"
10 SRC_URI="https://download.silicondust.com/hdhomerun/${PN}_${PV}.tgz"
11
12 LICENSE="LGPL-2.1+"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15
16 PATCHES=(
17         "${FILESDIR}/${PV}-use_shared_library.patch"
18 )
19
20 S="${WORKDIR}/${PN}"
21
22 src_prepare() {
23         default
24         #Remove forced optimization from Makefile
25         sed -i 's:-O2::' Makefile || die "Was the Makefile changed?"
26 }
27
28 src_compile() {
29         emake CC=$(tc-getCC) STRIP=:
30 }
31
32 src_install() {
33         dobin hdhomerun_config
34         dolib.so libhdhomerun.so
35
36         insinto /usr/include/hdhomerun
37         doins *.h
38 }