Use https by default
[gentoo.git] / media-libs / libdc1394 / libdc1394-2.2.3.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit autotools eutils multilib-minimal
8
9 DESCRIPTION="Library to interface with IEEE 1394 cameras following the IIDC specification"
10 HOMEPAGE="http://sourceforge.net/projects/libdc1394/"
11 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
12         https://dev.gentoo.org/~ssuominen/sdl.m4-20140620.tar.xz"
13
14 LICENSE="LGPL-2.1"
15 SLOT="2"
16 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
17 IUSE="doc static-libs X"
18
19 RDEPEND=">=sys-libs/libraw1394-2.1.0-r1[${MULTILIB_USEDEP}]
20         >=virtual/libusb-1-r1:1[${MULTILIB_USEDEP}]"
21 DEPEND="${RDEPEND}
22         virtual/pkgconfig
23         doc? ( app-doc/doxygen )"
24
25 src_prepare() {
26         epatch \
27                 "${FILESDIR}"/${PN}-2.2.1-pthread.patch
28
29         AT_M4DIR=${WORKDIR}/aclocal eautoreconf
30 }
31
32 multilib_src_configure() {
33         local myconf="$(use_enable doc doxygen-html)"
34         multilib_is_native_abi || myconf="--disable-doxygen-html --disable-examples"
35
36         # X is only useful for examples that are not installed.
37         ECONF_SOURCE="${S}" econf \
38                 $(use_enable static-libs static) \
39                 --program-suffix=2 \
40                 --without-x \
41                 ${myconf}
42 }
43
44 multilib_src_compile() {
45         default
46         multilib_is_native_abi && use doc && emake doc
47 }
48
49 multilib_src_install() {
50         default
51         multilib_is_native_abi && use doc && dohtml doc/html/*
52         find "${ED}" -name '*.la' -exec rm -f {} +
53 }