Use https by default
[gentoo.git] / media-libs / jpeg / jpeg-6b-r12.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 # this ebuild is only for the libjpeg.so.62 SONAME for ABI compat
8
9 PATCH_VER=1
10 inherit eutils libtool toolchain-funcs multilib-minimal
11
12 DESCRIPTION="library to load, handle and manipulate images in the JPEG format (transition package)"
13 HOMEPAGE="http://www.ijg.org/"
14 SRC_URI="mirror://gentoo/jpegsrc.v${PV}.tar.gz
15         https://dev.gentoo.org/~ssuominen/${P}-patchset-${PATCH_VER}.tar.xz"
16
17 LICENSE="IJG"
18 SLOT="62"
19 KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 m68k ~mips ~ppc ~ppc64 s390 sh ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
20 IUSE=""
21
22 DOCS=""
23
24 RDEPEND="!>=media-libs/libjpeg-turbo-1.3.0-r2:0
25         abi_x86_32? ( !<=app-emulation/emul-linux-x86-baselibs-20130224-r5
26                 !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] )"
27 DEPEND="${RDEPEND}"
28
29 src_prepare() {
30         EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/patch
31         epatch "${FILESDIR}"/${PN}-8d-CVE-2013-6629.patch
32         elibtoolize
33 }
34
35 multilib_src_configure() {
36         tc-export CC
37         ECONF_SOURCE=${S} \
38         econf \
39                 --enable-shared \
40                 --disable-static \
41                 --enable-maxmem=64
42 }
43
44 multilib_src_compile() {
45         emake libjpeg.la
46 }
47
48 multilib_src_install() {
49         newlib.so .libs/libjpeg.so.62.0.0 libjpeg.so.62
50 }