media-libs/gst-rtsp-server: bump to 1.14.2 for upstream bug fixes
[gentoo.git] / media-libs / gst-rtsp-server / gst-rtsp-server-1.14.2.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit gstreamer
7
8 DESCRIPTION="A GStreamer based RTSP server"
9 HOMEPAGE="https://gstreamer.freedesktop.org/modules/gst-rtsp-server.html"
10
11 LICENSE="LGPL-2+"
12 KEYWORDS="~amd64 ~x86"
13 IUSE="examples +introspection static-libs test"
14
15 # gst-plugins-base for many used elements and API
16 # gst-plugins-good for rtprtxsend and rtpbin elements, maybe more
17 # gst-plugins-srtp for srtpenc and srtpdec elements
18 RDEPEND="
19         >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
20         >=media-libs/gstreamer-${PV}:${SLOT}[introspection?,${MULTILIB_USEDEP}]
21         >=media-libs/gst-plugins-base-${PV}:${SLOT}[introspection?,${MULTILIB_USEDEP}]
22         >=media-libs/gst-plugins-good-${PV}:${SLOT}[${MULTILIB_USEDEP}]
23         >=media-plugins/gst-plugins-srtp-${PV}:${SLOT}[${MULTILIB_USEDEP}]
24         introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
25 "
26 DEPEND="${RDEPEND}
27         >=dev-util/gtk-doc-am-1.12
28 "
29
30 # Due to gstreamer src_configure
31 QA_CONFIGURE_OPTIONS="--enable-nls"
32
33 multilib_src_configure() {
34         # debug: only adds -g to CFLAGS
35         # docbook: nothing behind that switch
36         # libcgroup is automagic and only used in examples
37         gstreamer_multilib_src_configure \
38                 --disable-debug \
39                 --disable-valgrind \
40                 --disable-examples \
41                 --disable-docbook \
42                 --disable-gtk-doc \
43                 $(multilib_native_use_enable introspection) \
44                 $(use_enable static-libs static) \
45                 $(use_enable test tests) \
46                 LIBCGROUP_LIBS= \
47                 LIBCGROUP_FLAGS=
48
49         # work-around gtk-doc out-of-source brokedness
50         if multilib_is_native_abi ; then
51                 ln -s "${S}"/docs/libs/${d}/html docs/libs/${d}/html || die
52         fi
53 }
54
55 multilib_src_install() {
56         emake install DESTDIR="${D}"
57         # Handle broken upstream modifications to defaults of gtk-doc
58         emake install -C docs/libs DESTDIR="${D}"
59 }
60
61 multilib_src_install_all() {
62         einstalldocs
63         find "${ED}" -name '*.la' -delete || die
64
65         if use examples ; then
66                 insinto /usr/share/doc/${PF}/examples
67                 doins "${S}"/examples/*.c
68         fi
69 }