11adbd7c294965295ad9cda546426ab56c076afc
[gentoo.git] / media-libs / ganv / ganv-1.4.2.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 PYTHON_COMPAT=( python2_7 )
7 PYTHON_REQ_USE='threads(+)'
8 inherit waf-utils python-any-r1
9
10 DESCRIPTION="A GTK+ widget for interactive graph-like environments"
11 HOMEPAGE="http://drobilla.net/software/ganv/"
12 SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
13
14 LICENSE="GPL-3+"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="+fdgl +graphviz introspection nls"
18
19 RDEPEND="dev-cpp/glibmm:2
20         dev-cpp/gtkmm:2.4
21         x11-libs/gtk+:2
22         graphviz? ( media-gfx/graphviz[gtk] )
23         introspection? ( app-text/yelp-tools
24                 dev-libs/gobject-introspection[doctool] )"
25 DEPEND="${RDEPEND}
26         nls? ( virtual/libintl )"
27
28 DOCS=( AUTHORS NEWS README )
29
30 src_configure() {
31         waf-utils_src_configure \
32                 $(use graphviz || echo "--no-graphviz") \
33                 $(use fdgl || echo "--no-fdgl") \
34                 $(use nls || echo "--no-nls") \
35                 $(use introspection && echo "--gir")
36 }