93da478c00968e87aacf20718e356126c92d7a36
[gentoo.git] / media-libs / ganv / ganv-1.4.2-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 # oes not work with python3
6 PYTHON_COMPAT=( python2_7 )
7 PYTHON_REQ_USE='threads(+)'
8 inherit eutils flag-o-matic waf-utils python-any-r1
9
10 DESCRIPTION="A GTK+ widget for interactive graph-like environments"
11 HOMEPAGE="http://drobilla.net/software/ganv/"
12 SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
13
14 LICENSE="GPL-3+"
15 SLOT="0"
16 KEYWORDS="amd64 ~x86"
17 IUSE="+fdgl +graphviz introspection nls"
18
19 RDEPEND="
20         dev-cpp/glibmm:2
21         dev-cpp/gtkmm:2.4
22         x11-libs/gtk+:2
23         graphviz? ( media-gfx/graphviz[gtk] )
24         introspection? (
25                 app-text/yelp-tools
26                 dev-libs/gobject-introspection:=[doctool] )
27 "
28 DEPEND="${RDEPEND}
29         ${PYTHON_DEPS}
30         dev-util/glib-utils
31         nls? ( virtual/libintl )
32 "
33
34 PATCHES=(
35         "${FILESDIR}"/${P}-no-fdgl.patch
36 )
37
38 src_configure() {
39         append-cxxflags -std=c++11
40         waf-utils_src_configure \
41                 $(use graphviz || echo "--no-graphviz") \
42                 $(use fdgl || echo "--no-fdgl") \
43                 $(use nls || echo "--no-nls") \
44                 $(use introspection && echo "--gir")
45 }